Sunday, 1 February, 2009

And now compiz is working

I am going to continue my pointless rants about KDE and compiz.

I wanted downgrade KDE back to 3.5.10. I figured that there is no direct way of it. Apparently the "4" in KDE 4.* is not just a version number. KDE 4 is treated as a different software (I maybe wrong here so correct me if I am). Ergo, to downgrade KDE 4 I will have to downgrade to Hardy. Because KDE 3.* is not available in Intrepid. Wow...
Further, downgrading Ubuntu is technically possible but is a not so straight forward. For no apparent reason, I installed GNome along side KDE. And voila... Compiz is suddenly working like never before. It also provides most of the features I liked in KDE3. So now, I have finally settled down with KDE4.1. Amarok2 is the only thing that has issues (mainly coz I am using gstreamer backend for phonon).

Although compiz in KDE seems to be working well for most of the people out there (even without Gnome). I believe there is something in KDE compiz that still is loosely tied to Gnome. So it requires Gnome to be present in order to run properly. I should be doing more testing before making such propositions. But now that things are working well for me I simply do not care....